Bold B500 and B550: Compatible devices

bold-300x268.png

The B500 requires Bluetooth 2.1. 

The B550 requires a device with Bluetooth 4.0.

Good news! The vast majority of mobile devices currently in use support both Bluetooth 2.1 and 4.0. 

 

0 out of 0 found this helpful